T-Mobile FINALLY Rolling Out Android 4.1.1 Jelly Bean To The HTC One S

Screen Shot 2013-04-25 at 7.39.43 AM

What a great way to start the news day and no, your eyes are not deceiving you HTC One S owners, Jelly Bean is here, it’s really really here. The Android 4.1.1 update weighs in at a hefty 675.49MB and due to its size, can only be downloaded over a Wi-Fi connection.

The update brings the usual fare of an updated user interface to the Android experience in addition to several enhancements.” The update is expected to take around 10-20 minutes to install, which is a fraction of the amount of time compared to how long One S owners have waited for the update to actually arrive.

Hit your “Check for updates” option under settings and get going right this minute.
Screen Shot 2013-04-25 at 7.40.03 AM

Tags: , , ,

  • chewsta

    This update kills the battrey on this phone why!

  • keasycase

    I love this update… Everything is smother and my battery life is waaaay better

  • edzzz

    How can i remove autocorrect in texting? thanls

  • Nick

    My phone has received its update, and now my battery life is almost cut in half! Is anyone else experiencing diminished battery life on their Jelly Bean updated HTC One S?????

    • Delta

      Yes the battery wasn’t all that great prior to update and now it’s horrible. Basically a ticking timebomb counting down from 100 -> 0

    • http://twitter.com/ZamoraO OZ

      Same issue here. I am still going through the cycles of discharge/recharge after a full phone reset on Friday. I am not sure if it’s helping yet. Battery live has been horrible since the update.

  • http://twitter.com/ZamoraO OZ

    Opened a thread on T-Mobile Support. This is my reply: http://support.t-mobile.com/message/235651#235651

    “I experienced the same exact issue, and had the same services at the top (IPServices) which I tried all kinds of permutations to reduce its battery usage. It went away after 2 days, however, I am still having battery drainage problems. Right now the high usage is from Android OS itself. My battery drains even in airplane mode.

    Today I had 89% battery at noon, and used the phone for a few text message and 1 email reply. Wi-Fi enabled, Wi-Fi calling enabled. This is how I could squeeze as much battery as I could with ICS. by 7:20 PM my phone went dead. Mind you, I had urgent calls coming in that I could not pick the phone to answer. This is the first time in years that I had a dead phone and it happened; what are the chances right?

    I went ahead and called T-Mobile, escalated to retentions and asked for a replacement phone immediately. I cannot continue having the same issue.

    As soon as the new phone arrives, I will charge it to 100% and while plugged, upgrade to Jelly Bean. Go from there.

    This has been my battery history: http://pic.twitter.com/QwPoptEKxB

    • http://www.facebook.com/jay.chowder.1 Jay Chowder

      ip services also drained my battery. check apps that may be using gps which is google now. go to settings and in location settings disable the phone from sending its location on google now. After i did this, the ip services and gps is not turn on by itself. Battery is a lot better than it was on ics.

      • http://twitter.com/ZamoraO OZ

        Google now, or all checkboxes in location menu?

        Last time I disabled, I could not have the weather app update with current information. Do you have the same issue too?

        • http://www.facebook.com/jay.chowder.1 Jay Chowder

          help me spread the word with my solution

          i have the one s and after the update i had the same problem. I flipped through my apps and thought that it might have been google now that was draining my battery. you open google now-settings-privacy and accounts- manage location history-location settings- uncheck”enable location sharing and on the safe side i also unchecked enable location history. after this, ip services never turned on and my battery is way better than what it was with ics. I can last 3-4 days with at least 6 hours of heavy use. Google now still updates by itself and i encountered no problems after this.

        • http://twitter.com/ZamoraO OZ

          Thanks. On top of that, I have disabled Wi-Fi calling. I’m seeing better battery life.

        • Daniel Duran

          Props to you Oscar, you got the battery issue recognized and featured in David’s Tmonews blog

        • http://twitter.com/ZamoraO OZ

          Thanks for the heads up Daniel. I have gotten my replacement phone and it has ICS. I am still playing around with the options to see which ones help minimizing battery usage. So far I can confirm that Wi-Fi calling as well as location drain a lot of battery. Will continue testing.

          Thanks again.

    • Don

      Oscar the battery drainage may be due to you phone trying to either connect to wifi unsuccessfully or using other apps in the background. This is usually accompanied by the phone over heating. Shutting down the phone and allowing it to cool for 20/30 mins may help.

  • TB

    Does anybody have sensitivity issues with the touchscreen? The problem that I am having is that pulling down the notification bar would take several tries and would sometimes work correctly. I have not dropped my phone or any type of damage.
    PS: I do not have the same problem with the power drain like some other people!!!! I can finally go through a full day with charge unlike with ICS.

  • Don

    Ok Folks I have had some improvements by changing the wifi settings:

    Settings

    WiFi

    Menu

    Advanced

    Ensure that DNLA auto-IP is unticked…

    This may solve most of the Wifi connection issues for older Routers across most platforms.

  • Oma

    Is it possible to UNINSTALL the UPDATE